JUDELOGO
内部統制文書化支援ツール JUDE/Biz
システム要件
Biz ダウンロード
Biz製品FAQ
リリース情報
製品版サポート
Change Vision, Inc.
重要なお知らせ
かねてよりご案内の通り、2015年1月31日をもってJUDE/Bizの販売を終了いたしました。 また、サポートサービスは2016年1月31日をもって終了いたします。 お持ちのJUDE/Bizはサポート終了後も引き続きご利用いただけます。
JUDE/Biz 2.0で発生する不具合
および回避方法について
本ページに掲載している11件の不具合を修正したバージョン 2.0.1を 2007年11月26日にリリース致しました。
2.0をご利用の皆様は、2.0.1へのバージョンアップをお願い致します。

JUDE/Biz ダウンロードページ

2007年10月12日にリリースいたしました JUDE/Biz 2.0にて不具合が発生する場合がございます。 皆様にはご迷惑をおかけし、誠に申し訳ありません。不具合の内容と回避方法をお知らせしますので、 エラーの回避をお願い致します。

JUDE/Biz 2.0で発生する不具合の内容と回避方法

  1. JUDE/Biz 2.0を起動できない
  2. 業務フロー上でフロー記号を移動する際にエラーが発生
  3. バージョン1.xで作成したファイルを2.0で開くことができない
  4. 「閉じる(×)」ボタンで JUDE/Bizを終了する際、プロジェクトの保存を選択しても、プロパティの情報が保存されない
  5. コントロールチェックリストにおいて、選択項目を追加(拡張)した場合、表を直接編集する際、選択肢が表示されず、表が動作しなくなる
  6. 業務記述書において、選択項目を追加(拡張)したが、選択リストを追加していない場合、表を直接編集する際、選択肢が表示されず、表が動作しなくなる
  7. コントロールチェックリスト項目の列幅情報が、プロパティファイルのエクスポート、インポートで反映されない
  8. リスク・コントロール・マトリックスや業務記述書といった表形式のエディタで、外字登録した文字が正しく表示されない
  9. エラー発生時に表示されるアラートダイアログで、実際とは異なるパスでエラーログファイルの保存場所が表示される
  10. 選択項目の選択リストの変更が消え、連続で編集できない
  11. 全てのレーンを削除した後、レーンを作成するとエラーが発生する

  1. JUDE/Biz 2.0を起動できない

    • 不具合内容
      JUDE/Biz 2.0をインストールした後、起動できなくなる
    • 発生条件
      JUDE/Bizのインストールフォルダ配下(標準インストールの場合 C:\Program Files\JUDE-Biz)、 およびユーザーホームの両方にライセンスキーファイルがある場合に発生
    • 回避方法
      JUDE/Bizのインストールフォルダ配下(標準インストールの場合 C:\Program Files\JUDE-Biz)にある ライセンスキーファイル(JUDE_License_User_Biz.xml)の名称を変更(推奨する操作方法)、または削除する。
  2. 業務フロー上でフロー記号の移動やレーン幅を調整するとエラーが発生

    • 不具合内容
      バージョン1.xで作成した業務フローを2.0で開き、次の操作をした場合にエラーが発生 フロー記号を移動する / レーン幅を調整する
    • 発生条件
      バージョン1.xで作成・編集されたプロジェクトファイルを、バージョン2.0で初めて開く、あるいは、 2.0を使用して一度も更新していない文書を含んだプロジェクトファイルを開く場合に、次のいずれかの方法を用いるとエラーが発生
      1) プロジェクトファイル(.jbiz)のアイコンをダブルクリックして開く
      2) プロジェクトファイルのアイコンを、JUDE/Bizのアイコン上にドラッグして開く
    • 回避方法
      JUDE/Bizを起動してから、次のいずれかの方法でプロジェクトファイルを開く
      1) 上部メインメニュー[ファイル]→[プロジェクトファイルを開く]から、プロジェクトファイルを選択して開く
      2) [既存のプロジェクトファイルを開く]アイコンから、プロジェクトファイルを選択して開く

    このエラーは全ての文書が 2.0で更新済みの場合には発生しません。2.0での更新・未更新は、 プロジェクトビュー(画面左上)の[図・表]タブ上に表示される更新日欄から確認できます。 2.0でプロジェクトファイルに含まれる文書(フローや業務記述書など)を一括で更新する方法は次の通りです。
    1. プロジェクトファイルを開く。
      注:プロジェクトファイルを編集した場合は、必ず編集内容を保存してから次の操作をします。
    2. [ファイル]→[他のプロジェクトから業務をインポート]を選択すると、ファイルを選択するダイアログが開きます。
    3. 現在開いているプロジェクトファイルを選択して、[開く]を押下すると、[インポートする業務の選択]ダイアログが開きます。
    4. 「処理種別」が、全て「上書き」になっていることを確認して、[全てを選択]→[了解]ボタンを押下します。
    5. プロジェクトファイルを保存します。
    プロジェクトファイルに含まれる全ての文書を一括で更新できました。
  3. バージョン1.xで作成したファイルを2.0で開くことができない

    • 不具合内容
      バージョン1.xで作成したファイルを2.0で開く際、砂時計マークが表示され、画面が固まったように見える
    • 発生条件
      レーンに組織やITシステムを関連付けている文書を含んだプロジェクトファイルに、不正なモデルが存在する場合、プロジェクトファイルを開く際に発生
    • 回避方法
      JUDE/Biz 2.0でプロジェクトファイルを開き、「砂時計が表示された状態」で、上部メインメニューの [ファイル] → [プロジェクトファイルの別名保存] を押下して、ファイルを別名で保存する。
  4. 「閉じる(×)」ボタンで JUDE/Bizを終了する際、プロジェクトの保存を選択しても、プロパティの情報が保存されない

    • 不具合内容
      「閉じる(×)」ボタンを用いてJUDE/Bizを終了する際、プロジェクトの保存を選択しても、プロパティの情報が保存されない
    • 発生条件
      「閉じる(×)」ボタンを押下して表示される「ファイルの内容が変更されています。保存しますか?」というダイアログで、 「はい」をクリックして保存した場合、再びプロジェクトファイルを開くと、設定が変更されていない
    • 回避方法
      ツールバーの「プロジェクトファイルの保存」アイコンをクリックして保存した後、プロジェクトファイルを閉じることで回避できます。
  5. コントロールチェックリストにおいて、表を直接編集する際、選択肢が表示されず、表が動作しなくなる

    • 不具合内容
      コントロールチェックリストにおいて、選択項目を追加(拡張)した場合、表を直接編集するときに選択肢が表示されず、表が動作しなくなる
    • 発生条件
      コントロールチェックリストにおいて、選択項目を追加(拡張)した場合に発生
    • 回避方法
      エディタではなく、ダイアログを利用して編集することで回避できます。
    1. 上部メインメニュー[ツール]→[コントロールチェックリスト項目の設定]を選択して表示されるダイアログで、データタイプが「選択」の項目を作成し、選択項目を追加
    2. コントロールチェックリスト上では選択項目の値を編集しない
    3. フロー上のリスクアイコン(デフォルトでは赤い三角の印)をダブルクリックすると、「リスクコントロール項目の設定」ダイアログが表示される (リスクアイコンを右クリックして表示される「リスクとコントロールの編集」メニューを選択しても良い)
    4. 「リスクとコントロール項目の設定」ダイアログで選択項目の値を編集する
    5. 「リスクとコントロール項目の設定」ダイアログ右側の「コントロール一覧」下方にある「チェック項目」ボタンを押下して表示される「チェック項目の設定」ダイアログにて、 選択項目の値を選択。「適用」ボタンを押下。
    6. 「リスクとコントロール項目の設定」ダイアログに戻り、「適用」→「了解」の順に押下。
  6. 業務記述書において、選択項目を追加(拡張)したが、選択リストを追加していない場合、表を直接編集する際、選択肢が表示されず、表が動作しなくなる

    • 発生条件
      業務記述書において、選択項目を追加(拡張)したが、選択リストを追加していない場合に発生
    • 回避方法
      処理関連項目の設定で、データタイプが選択の項目を作成する際、「選択項目の追加」で項目を追加する
  7. コントロールチェックリスト項目の列幅情報が、プロパティファイルのエクスポート、インポートで反映されない

    • 不具合内容
      コントロールチェックリストで列幅を変更した後、プロパティファイルをエクスポートしても、列幅情報が保存されない。そのため、プロパティファイルを別のコントロールチェックリストにインポートした場合、元の幅で表示される。
    • 回避方法
  8. リスクコントロールマトリックスや業務記述書といった表形式のエディタで、外字登録した文字が正しく表示されない

    • 不具合内容
      業務記述書・リスクコントロールマトリックスのダイアグラムエディタ画面、および印刷時に外字登録した文字が「・」と表示される。
    • 発生条件
      登録した外字をJUDE/Bizで利用している場合
    • 回避方法
      「J2RE 1.4.2_14」を使用してJUDE/Bizを起動します。
    1. http://java.sun.com/products/archive/j2se/1.4.2_14/index.html より、 J2RE 1.4.2_14をダウンロード、インストールします。(既にインストール済の場合は、この手順は不要です)
    2. JUDE/Biz のインストールフォルダ内にある[jre]フォルダの名称を別のフォルダ名に変更します。
  9. エラー発生時に表示されるアラートダイアログで、実際とは異なるパスでエラーログファイルの保存場所が表示される

    • 不具合内容
      エラー発生時に表示されるアラートダイアログにて、エラーログファイルの保存場所のパスが間違っている
    • 対応内容
      アラートダイアログの表示内容を修正
  10. 選択項目の選択リストの変更が消え、連続で編集できない

    • 不具合内容
      選択項目の選択リストを変更する際、2回以上連続で編集することができない
    • 発生条件
      選択項目の選択リストを変更する場合に発生
    • 回避方法
      選択リストを変更する際、1件変更するごとにダイアログを閉じ、再度ダイアログを開いて編集する
  11. 全てのレーンを削除した後、レーンを作成するとエラーが発生する

    • 不具合内容
      レーンに関連する不正なモデルが存在する場合、全てのレーンを削除した後、レーンを作成するとエラーが発生
    • 発生条件
      バージョン1.xにてフローをコピー&貼り付けによって作成したプロジェクトファイルを、2.0で開き、全てのレーンを削除した後、レーンを作成する
    • 回避方法
回避方法を実施後も問題が解決しない場合は、お手数ですがお問い合わせください。
件名 「JUDE/Biz 2.0で発生する不具合について」
jude-info アットマーク change-vision.com (アットマークは画像です。お手数ですがご入力ください。)

About us    Copyright © 2006-2015 Change Vision, Inc. All rights reserved.