JUDELOGO
JUDE changes to astah*
FAQ
License FAQ
JUDE/Share FAQ
Change Vision, Inc.
FAQ
End Of Life and support for JUDE products
Technical support and download of JUDE products were discontinued on April 30th, 2012.
Please use new editions, Astah.

Others ( ChangeVision Members Login )

  1. I forgot my password to log into ChangeVision Members. Can I reissue it?
  2. Where can I find information for particular version of JUDE such as what's new in it and fixed bugs..etc?

Setup Troubleshootings, etc.

  1. I cannot start up JUDE.
  2. I want to use a specific version of the JavaVM.
  3. I get a warning says "J2SDK version is old".
  4. I cannot start up JUDE by batch file, and I see "Out of environment space" warnings.
  5. The JUDE window flickers on my computer and my PC restarts.
  6. I am unable to open JUDE files.
  7. How can I run JUDE on Linux?
  8. Where can I find a log file that I attach when I send a bug report.
  9. Where can I find property files for JUDE? (Since Ver 5.0)

System Requirements and Version, etc.

  1. What is the "JudeDefaultModel"?
  2. Where is the JudeDefaultModel until version 3.2.x and how do I customize it?
  3. Where is the JudeDefaultModel of version 5.0.x or 5.1.x and how do I customize it?
  4. Which file opens as default model in version 5.2.x or later?
  5. Can I use JUDE on Linux or MacOS?
  6. What I type into strings does not appear in the Diagram Editor.
  7. Can I use Japanese with JUDE?
  8. How can I attain better performance on JUDE?
  9. It takes rather too long to save or JUDE seems to have frozen when I save project file by [save as].

Features

  1. How can I customize format for Entity Definition Report?
  2. Can I sort order of Entities by physical name when I export Entity Definition Report?
  3. Does JUDE support Object Diagrams?
  4. Can I paste diagrams on Microsoft Word, Excel or PowerPoint?
  5. The "Export HTML" function does not work.
  6. Why are class diagrams not generated by the "Import Java" function?
  7. I cannot import Java source code.
  8. Can I bind source codes and diagrams using JUDE?
  9. Can I import/export model data from/to other tools?
  10. Does JUDE support any feature that we can use for Team development?
  11. I cannot shorten length of some ExecutionSpecifications (Activations) in Sequence Diagrams.
  12. Can I open project files that are created in JUDE/Professional using JUDE/Community?
  13. Can I merge project files that I have created with JUDE/Community using the merge function of JUDE/Professional?
  14. How can I represent Actors in Sequence diagram?

About Free Version

  1. Can I use JUDE/Community in my school and is it okay to distribute in the institution?

Others ( ChangeVision Members Login )

  1. I forgot my password to log into ChangeVision Members. Can I reissue it?

    Yes, you can reissue your password.
    1. Access to ChangeVision Members Service Top Page.
    2. Select [Reissue Password] from left menu.
  2. Where can I find information for particular version of JUDE such as what's new in it and fixed bugs..etc?

    Please read the Release Note. It tells what enhancements and improvements have been done and list of fixed bugs for each version.
    There are two ways to open the Release note.
    • Click on the version number in Update Information page.
    • Go to [Start] - [All Programs] - [JUDE Professional (or Community) ] - [Release Note]
    Bug information is also available at Bug Report forum in JUDE Community Site.

System Requirements and Version, etc.

  1. What is the "JudeDefaultModel"?

    JudeDefaultModel is a default project file that opens automatically every time you create a new project until Version 5.1.1. You can customize it as you like. (e.g. Add Java API or common API models among project teams..etc)
    Please follow the link for how to customize JUDE Default model.
    For JUDE 3.2.x or earlier version, click here. For JUDE 5.0.x or 5.1.x, click here. For JUDE 5.2.x or later, click here.
  2. Where is the JudeDefaultModel until version 3.2.x and how do I customize it?

    JudeDefaultModel.jude is stored in JUDE install folder in version 3.2.x or earlier. If you would like to use customized the default model,
    1. Create a new project file and customize as you like.
    2. Save this project file as [JudeDefaultModel.jude] and save it in your JUDE install folder.
  3. Where is the JudeDefaultModel of version 5.0.x or 5.1.x and how do I customize it?

    JudeDefaultModel.jude is stored in two directories.
         - USERHOME/.jude/professional folder (community) or
         - Your JUDE Install Folder
    If you would like to use customized the default model,
    1. Create a new project file and customize as you like.
    2. Save this project file as [JudeDefaultModel.jude] in either directory shown above.
    If there are two default models in both directories, one in the former folder will be used.
  4. Which file opens as default model in version 5.2.x or later?

    Since version 5.2, you can choose which project file (Template) to use as default model.
    1. Go to [Tool] - [System Properties] - [File] in Main Menu
    2. Choose a model you would like to open in [Create New Project By] out of three options.
      - None
      - User's Template (Customized Template (.jude file) that is saved in USERHOME\.jude\professional(or community)\template\project
      - JUDE Built-In Template (stored in JUDE Install Folder\template\project)
  5. Can I use JUDE on Linux or MacOS?

    JUDE may run on Linux or Mac OS, however we do not officially support Linux or MacOX for JUDE to run on. (See System Requirements).
    Please see the FAQ 11 for how to set up.
    We strongly advise you to use the recommended Java environment to run JUDE on these non-Windows platforms. For sharing information about running JUDE on Linux or Mac OS, please post on JUDE Users Community Site.
  6. What I type into strings does not appear in the Diagram Editor.

  7. Can I use Japanese with JUDE?

    Yes. In the GUI, Japanese menu items will be shown in Japanese versions of Windows.
    1. Open JUDE batch file (jude.bat or jude-pro.bat) with Text Editor.
      (You can find it in JUDE install folder)
    2. Modify "set USER_LANGUAGE="
    3. Save the batch file and start JUDE.
  8. How can I attain better performance on JUDE?

    The performance level of JUDE depends on the RAM capacity of your machine.
    Try following methods.
    • Use the latest Java environment.
      (See FAQ 4. "I want to use a specific version of the JavaVM.")
    • Turn off the mouse cursor tracing option.
      (In some environments, having this option on could make the rendering slower.)
    • Tune some garbage collection settings. (When the value of INITIAL_HEAP_SIZE is set to 16m, the garbage collection does not work fully unless your computer uses the memory more than 16MB)
      *Caution*
      Do not set the value of MAXIMUM_HEAP_SIZE too small because if you do, it could cause "OutOfMemoryErrors" and JUDE will not work properly.
  9. It takes rather too long to save or JUDE seems to have frozen when I save project file by [save as].

    This may happen when you are running JUDE on Java 6. Please try following solutions.
    • Use Java 5 instead of Java 6 to run JUDE on.
      (See FAQ 4. "I want to use a specific version of the JavaVM."
    • Clean up files in Desktop, My recent documents, My documents,,etc if there are large files, or zip files in those folders.
    • Use other Look&Feel except Windows. ([View] - [Look & Feel] in Main Menu)

Setup Troubleshootings, etc.

  1. I cannot start up JUDE.

    Ensure that you are using the recommended JRE. See the System Requirements for JUDE.
  2. I want to use a specific version of the JavaVM.

    See what versions of Java JUDE supports
    1. Open the JUDE start-up batch file (jude-pro.bat or jude.bat) with text editor. You will find the batch file in JUDE install folder.
    2. Remove "rem" from the following 2 lines, and change the value for "JAVA_HOME" to the install folder of your preferred J2SDK.
      rem set JAVA_HOME=C:\j2sdk1.x.x_xx
      rem set PATH=%JAVA_HOME%\bin
                     to
      set JAVA_HOME=[the install folder of your preferred J2SDK]
      set PATH=%JAVA_HOME%\bin
    3. Rename "jre" folder which you can find in JUDE install folder if you had used JRE-bundled version of installer to install JUDE.
    4. Launch JUDE again by double-clicking JUDE icon on desktop or Start menu in Windows.
  3. I get a warning says "J2SDK version is old".

    An old JavaVM is used to run JUDE. Please specify appropriate Java install folder in batch file.
    (Please refer to [FAQ 4."I want to use a specific version of the JavaVM."])
  4. I cannot start up JUDE by batch file and I see "Out of environment space" warnings.

    Change the memory size for environment variables as follows:
    1. Right-click on the batch file and open [Property].
    2. Select the [Memory] tab.
    3. Change the default value for environment variables from [Auto] to a suitable value.
    4. Click [OK].
  5. The JUDE window on my computer flickers and my PC restarts.

    Rendering problems can be caused by the display driver or the Java environment.
    If these problems are not solved by installing the latest version of the display driver or of Java, please try the following option:
    -Dsun.java2d.noddraw=true
    Example ) How to add this option in JUDE start-up batch file
    1. Open the JUDE start-up batch file (jude-pro.bat or jude.bat) with text editor. You will find the batch file in JUDE install folder.
    2. You will see the following line in about 44th line (This varies depending on what edition of JUDE you use), so add this "-Dsun.java2d.noddraw=true" option to it.
      i.e.) set JAVA_OPTS=-Xms%INITIAL_HEAP_SIZE% -Xmx%MAXIMUM_HEAP_SIZE% -Xss%STACK_SIZE% -Dsun.java2d.noddraw=true
  6. I am unable to open JUDE files.

    JUDE project files (.jude) are upward compatible. If project files are edited by new version, they cannot be opened in older version of JUDE. For information about model versions, click here.
    If you cannot open project files using appropriate version of JUDE, please change the stack size in JUDE batch file.
    1. Open JUDE batch file (jude.bat or jude-pro.bat) with Text Editor.
      You can find the batch file in JUDE install folder.
    2. In about 11 lines from the top, you can find this line;
      "set STACK_SIZE=2m"
      Change "2m" to 3m" to make the stack size bigger.
    3. Save the batch file and start JUDE.
  7. How can I run JUDE on Linux?

    Linux is not a supported operation system to run JUDE on. See the System Requirements.
    How to run JUDE on Linux
    1. Set up Java environment.
    2. Unzip JUDE download file (zip).
    3. Edit Shell script (jude) for your running environment.
    4. Add the execute permission to Shell script (chmod 755 jude).
    5. Execute Shell script (jude).
  8. Where can I find a log file that I attach when I send a bug report.

    A log file ijude.logj is stored in your home directory.
    You can see where it locates from [Help] - [Bug report] in Main Menu of JUDE.
    Please attach a log file when you send us a bug report since it needs to be analyzed.
  9. Where can I find property files for JUDE? (Since Ver 5.0)

    Since Ver 5.0, all property files for JUDE including JUDE license key have relocated to ;
    - If you are using JUDE/Professional - Userhome\.jude\professional
    - If you are using JUDE/Community - Userhome\.jude\community

Features

  1. How can I customize format for Entity Definition Report?

    1. Go to [Tool]-[ER Diagram]-[Export Entity Definition Report] in Main Menu
    2. [Export Entity Definition Report] dialog opens. Click on [New Template] button that is on the right bottom of dialog.

      Remember the Template name and where it is generated shown above.
    3. Close the dialog.
    4. Open the template file (.xls) directly that is generated where you checked at step 2. Customize it as you like. (You can create header and footer.etc)
    5. Overwrite the template file.
    6. Choose customized template file when exporting Entity Definition Report.
  2. Can I sort order of Entities by physical name when I export Entity Definition Report?

    Yes. By clicking on the top of [Physical Name] field, you can sort order of Entities by Physical name to export into Entity Definition Report.
  3. Does JUDE support Object Diagrams?

    Yes. You can draw Object Diagram in Class Diagram in both of JUDE/Community and JUDE/Professional. Please use [Object] and [Link] from Tool Bar of Class Diagram to draw.
  4. Can I paste diagrams on Microsoft Word, Excel or PowerPoint?

    Yes, You can copy & paste diagrams with BMP, PNG, EMF format on Microsoft Word, Excel and PowerPoint. (Copying in EMF format is supported in JUDE/Professional only).
    For details, go to Copy and Paste to Word, Excel (EMF format). You can modify pasted EMF images after ungrouping them in Microsoft Word, Excel and PowerPoint. Some images may get distorted when ungrouping occasionally. However we do not provide Technical Support for issues on Microsoft Word, Excel and PowerPoint after pasting diagrams. Although we would appreciate if you inform us any issues that happened while copying and pasting so we can try to resolve them.
    See "Save as Image" of JUDE TIPS.
  5. The "Export HTML" function does not work.

    To use this function, you need to copy the lib/tools.jar file, included in J2SDK to the install folder of JUDE. JUDE/Professional 5.4.1 or earlier
    Copy the lib/tools.jar file, included in J2SDK 1.4.x, to the install folder of JUDE.
    * lib/tools.jar file of J2SDK of 5.0, 6.0 is not currently supported.
    JUDE/Professional 5.5 or later
    Copy the lib/tools.jar file, included in J2SE5.0 or 6.0, to the install folder of JUDE.
    The tools.jar of J2SE1.4 is not applicable to export HTML since ver 5.5 (including this beta version).
  6. Why are class diagrams not generated by the "Import Java" function?

    [Import Java] will not generate Class Diagrams automatically. To generate Class Diagrams with imported Java source files, select [Auto Create Class Diagram] from the Pop-Up Menu of Package in the Structure Tree. See "Import Java" of JUDE TIPS.
  7. I cannot import Java source code.

    The target Java source code can be imported only if it compiles without errors. Classes referred to in the target Java source code may be created under the project directly if you did not set the classpath. Please make sure that you have set up appropriate encode in System Properties.
    1. Go to [Tool] - [System Properties] in Main Menu.
    2. Open [File] Tab then choose an appropriate encode in [Charset of importing java files] option.
  8. Can I bind source code and diagrams using JUDE?

    Importing and exporting are available, however Round-trip engineering is not currently supported so it will lose implementations for operations (methods).
  9. Can I import/export model data from/to other tools?

    JUDE/Professional supports data compatibility with Rational Rose(TM) paritially via XMI. We are planning on enhancing the compatibility of JUDE with other products in the future. Click here for more information.
  10. Does JUDE support any feature that we can use for Team development?

    Yes, try the [Reference Model Management] feature ([File] - [Reference Model Management]) of JUDE/Professional. This feature is recommended for those who are looking for a substitution for JUDE/Server also. To see how to use this feature to make your Team development work with, read the guide. "Team Development with JUDE and Version Control System" (9th August 2007, PDF 332KB)
  11. I cannot shorten length of some ExecutionSpecifications (Activations) in Sequence Diagrams.

    If ExecutionSpecifications (Activations) originates Messages to other ExcutionSpecifications, you cannot make the former ExecutionSpecifications shorter than ones that the messages lead.
  12. Can I open project files that are created in JUDE/Professional using JUDE/Community?

    Yes. You can open project files that are created in JUDE/Professional using JUDE/Community as long as the model version of JUDE/Community is appropriate. Please see the "Compatibility between JUDE Products" for details about the compatibility. Diagrams that are supported in JUDE/Professional only (Flowcharts, ER Diagrams, CRUD, Data Flow Diagrams and Mind Maps) would open read-only.
  13. Can I merge project files that I created with JUDE/Community using the merge function of JUDE/Professional?

    Yes. You can merge project files that are created with JUDE/Community using JUDE/Professional. ( [File] - [Merge Project] ) Please make sure that you use the same or higher model version of JUDE/Professional to merge with. Go to "Compatibility between JUDE Products" for details about the compatibility information of JUDE.
  14. How can I represent Actors in Sequence diagram?

    Version 5.5 or later
    1. Select an Actor from dropdown list of Lifeline.
    2. Click on a Diagram

    Version 5.4 or earlier
    You are able to represent Actors in Sequence diagrams in JUDE.
    1. Create an Actor in the Structure Tree (The top left pane)
      Open the pop-up menu of the Project and then select [Create Model] - [Add Actor].
    2. Open a Sequence diagram, drag the Actor from the Structure Tree and drop it onto the Sequence diagram.



About Free Version

  1. Can I use JUDE/Community in my school and is it okay to distribute in the institution?

    Yes, you can use Astah Community (new edition) in school and you may distribute it up to 50 computers as long as you have our permission. Please see Redistribution of Astah Community (new edition) for how to apply for permission to distribute.

About us    Copyright © 2006-2012 Change Vision, Inc. All rights reserved.